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Introduction
Read This

What is DigiPro?

•

Even if you hate manuals, it is important that you read this
introduction and the Quick Tour pages.

•

If you have DigiPro version 1.26 or earlier on your computer,
we suggest that you remove it before installing later versions.
This will not affect your data files or your unlocking key.

•

If you are working on an NTFS system (Windows NT 4,
2000, XP, or later), you may find that administrator rights are
required to install DigiPro. See your IT person for help.

DigiPro software is used to process and plot inclinometer data.
It creates high-resolution graphs and provides advanced
routines for identifying and correcting systematic errors.
DigiPro works with the project databases created by DMM for
Windows. If your inclinometer readings are not in this format,
see Appendix A.
DigiPro is not free software. It must be purchased. However,
when you first install DigiPro, purchased or not, it will run 45
times, so you can get some work done without worrying about
licensing. Read “About Unlocking Keys” on the next page.

Installing DigiPro
from a Resource CD
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1.

Remove any earlier version of DigiPro first. Doing this will
not affect your data or your unlocking key.

2.

Insert the Resource CD in your CD-ROM drive. The CD will
start automatically on some computers. On other computers,
you have to open and close the CD-ROM drive a second time
to make Autostart work.

3.

The browser window appears: click on Software.

4.

The software page appears: click on DigiPro for Windows.

5.

The DigiPro page appears: click on “Download DigiPro.”

6.

The File-Download dialog appears: choose "Run this program
from its current location" and click OK. You may see an security warning. Click Yes to continue the install.

7.

Follow on-screen instructions. You may be asked to restart
your computer more than once.
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Installing DigiPro
from a Setup File.

About Unlocking Keys

To obtain a key

To enter the key
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If you downloaded DigiPro from www.slopeindicator.com, you
have a setup file named “setupdpwin.exe” on your hard disk.
1.

Remove any earlier version of DigiPro first. Doing this will
not affect your data or your unlocking key.

2.

Click the Start button and choose Run.

3.

The Run dialog appears: click the Browse button to navigate
to the setup file that you downloaded.

4.

Select the setup file (setupdpwin.exe) and click Open.

5.

Click OK when the Run dialog reappears.

6.

Follow on-screen instructions. You may be asked to restart
your computer more than once.

After DigiPro is installed, it will run 45 times. After that, it will
stop running. To remove the run-limitation, you must purchase
DigiPro and request an unlocking key (a coded number). If you
have already purchased DigiPro, we have your company and city
in our database, but you must contact us for the key. Follow the
steps below:
1.

Find your DigiPro serial number. Start DigiPro. When the
start screen appears, click on the "License" button. A dialog
appears with the serial number.

2.

Use one of the methods below to contact us. We need your
serial number, name, company, and city.

•

Visit www.slopeindicator.com. Click on “Support,” then click
on “Get a DigiPro Key” and fill out the form.

•

Call Slope Indicator or your local distributor.

•

Fax Slope Indicator or your local distributor.

3.

We will generate a key to match your serial number and give it
to you.

1.

Start DigiPro. The start screen appears. Click on License.

2.

Check that your serial number is the one that you sent us,
then click on Modify.

3.

Enter your the unlocking key, and click OK.

4.

You should see the message: “This copy of DigiPro is fully
licensed for this computer.”
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Quick Tour
Start DigiPro

Click on the DigiPro shortcut, or go to:
Start > Programs > DigiPro > DigiPro.exe. Click Continue.

Click on the
Continue button.

Open a Database

DigiPro displays the Open File dialog. Choose “Sample.MDB.”
If you don’t see it, navigate to C:\Program Files\DigiPro\Data.

Choose an Installation
and Create a Report

DigiPro displays a list of the installations in the database.
Select the top one, SR18 IN1, and click New to create a report.

Installation List
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Reports (graphs) are normally
listed here. There are no reports
yet, so click New to create one.
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Choose a
Report Template

DigiPro displays a list of report templates. Each template offers a
different type of graph. Choose “Cumulative Displacement,
English Sample.” Click Open.

If you use metric data, you can hide
the english-unit templates, and vice
versa. You can also make your own
templates.

View and Modify
the Report

The report appears with two graphs. Click on either graph to
open the report properties dialog. Using the report properties
dialog, you can select different surveys, modify scales and labels,
add text to the title block, and make other changes.

Click on either graph
to open the report
properties dialog.
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Save the Report

Click the disk icon or choose File > Save As >Report. Enter a
name, and click OK. DigiPro stores the graph type and all the
settings for the graphs.

Close the Report

Click the X in the upper right corner of the graph. Close the
report properties dialog too.

To close the dialog or graph, click the X box.

Open the Report
to Recreate the Graphs

Select the report and click Open. DigiPro recreates your graphs.
In addition, DigiPro automatically includes any new surveys
that were added to the database, so the graphs are updated too.

Reports are listed in the reports
window. To recreate a graph,
select a report and click Open.

Click Open to
open a report.

Print the Report

When the graph appears on screen, click on the printer icon, or
choose Print from the File menu.

This prints just the
graph. You can also
print a listing of the
current survey.
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Creating Reports
Overview of Reports

Creating a Report
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•

It’s easy to make reports: simply open a report template and
save the resulting graph.

•

Reports save time. You can reproduce or update a graph with
just two mouse clicks.

•

Reports can be customized. For example, you can specify two
different types of graph for the report.

•

You can create as many reports as you need.

•

You can save the report as a template.

These basic steps are explained in detail on the following pages.
1.

Open a database.

2.

Select an installation.

3.

Choose a report template.

4.

Save the report.
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Open a Database

How to find
your database

1.

Start DigiPro, and click the Continue button.

2.

The Open File dialog appears. DigiPro displays the most
recently opened folder.

3.

Select your database, and click Open.

•

If you can’t see your database, click in the “Look-in” field to
navigate to a different folder or drive.

•

The default location used by DMM for Windows is:
C:\Program Files\ DMMWin\Projects.

•

DigiPro keeps a list of the last five databases that you opened.
To see this list, click on the File menu (Close the Open File
dialog first). The databases are listed at the bottom of the
menu.

How to create
a database

If you don’t have a database, you must create one with DMM for
Windows. DMM can also convert and import data. DMM is a
free download from www.slopeindicator.com. See Appendix A
for more information.

Select an Installation

After you open a project database, DigiPro displays the
“Installations and Reports” dialog. The left side of this dialog
shows a list of installations. Click on the installation of interest.

Selected installation
List of reports for this
installation

New creates
a new report.

New vs Open
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Open displays an
existing report.

After you select an installation, you can choose to create a new
report or open an existing report.
•

To create a new report, click New.

•

To open an existing report, select it and click Open.
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Choose a
Report Template
English-Units
or Metric-Units?

If you clicked New in the previous step, DigiPro displays a list of
report templates. Each template offers a different type of graph.
Graph types are explained on the following page.
1.

Select a template. Note
that there are Englishunit templates and
metric-unit templates.
It is important to choose
correctly because this
controls how readings are
processed.

•

Choose English if you use
an English-unit probe.

•

Choose metric if you use
a metric-unit probe.

2.

Click Open.

If your data is metric, you don’t need
English unit templates. Remove the
checkmark to hide them.

Note: DigiPro allows you to change the displayed units later, if
necessary, but at this point, you must choose according to your
probe units.

Creating Templates

To Create a
Custom Template

You may find it convenient to make your own templates. For
example, you may want templates that have:
•

A title block with your company’s name and logo.

•

Standard depths.

•

Different types of graph in the same report.

1.

Open a report. Modify it as needed.

2.

Choose File > Save As > Template.

3.

The new template will appear in the Report Templates
dialog.

Note: DigiPro’s templates are stored in the “templates.mdb” file
in the DigiPro\System folder. You can copy this file to other
computers.

DigiPro for Windows, 2004/1/08
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Graphs for Analyzing
Movement
Cumulative
Displacement

These graphs are the standard graphs used to analyze the
behavior of the ground.
Displacements are changes in the position of
the casing and are assumed to be equivalent
to ground movement. A displacement graph
requires at least two surveys: an initial survey
and a current survey. The initial survey does
not appear on the graph.
In a cumulative displacement graph, the
plotted point at any depth is the sum of
incremental displacements from the reference point (typically the bottom). The graph
shows how subsurface movement relates to
movement at the surface. Shear movements
are easily seen.

Incremental
Displacement

This graph shows displacements at discrete
depths. A growing “spike” indicates movement. The graph at right uses the same data
as the cumulative displacement plot above.
No summing is involved, so systematic error
is minimized.

Time Displacement:

This graph shows the rate of movement at one or more zones.
A steepening slope represents accelerating movements.
The plotted value
for each zone is the
difference between
the displacement
value at the top of
the zone and the
displacement value
at the bottom of the
zone. Zones are set
in the “zone” tab of
the report properties dialog.

DigiPro for Windows, 2004/1/08
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Graphs for Diagnosing
Systematic Error
Cumulative
Deviation

These graphs are generally used for troubleshooting or verifying
that graphs represent movements accurately.
This graph shows the profile of the casing
relative to vertical. Drillers can use this graph
to see borehole drift.
The plotted point at any depth is the sum of
incremental deviations up to and including
that depth. (Deviations are defined below).
In error analysis, this graph is used to show
the potential for systematic error due to
cross-axis tilt and a rotation of the sensitive
axis of the inclinometer probe.

Incremental
Deviation

This graph shows the deviation at each depth.
This represents the curvature of the casing.
The drawing at left shows deviation. The
angle of tilt is measured by the inclinometer,
the hypotenuse is the measurement interval
(typically the distance between the wheels)
and the side opposite the angle is the deviation.
In error analysis, this graph is used to show
the potential for systematic error due to casing curvature and settlements or inaccurate
depth control.

Checksum
and Difference Checksum

Checksums are the sum of the “0” and “180”
readings at each depth.
In error analysis, this graph provides an
indication of the potential for systematic
error due to bias shift. A tilted plot may
indicate problems with the electronics of the
sensor.
The difference-checksum graph shows
changes in checksum, and removes variations
that are due solely to characteristics of the
installed casing.

DigiPro for Windows, 2004/1/08
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Save the Report

Naming a Report
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After you have selected a template and clicked Open, DigiPro
displays the new report.
1.

Choose File>Save from the menu or click the disk icon.

2.

The Save As dialog appears. Enter a name for the report and
click OK.

•

A simple name, such as “Cumulative Displacement” is
sufficient, since it indicates the kind of graph that the report
will produce.

•

There is no need to make unique names for reports. Each
installation has its own list of reports. For example, you can
have a report named “cumulative displacement” for each of
your installations. In fact, this is recommended.

•

To rename a report, right-click on the report name and
choose “Rename” from the pop-up menu.
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Modifying Reports
Overview

Open a Report

Open the
Report Properties Dialog

The basic steps required to modify a report are:
1.

Open the report.

2.

Open the Report Properties dialog.

3.

Modify the properties for each graph.

4.

The settings that you have changed are saved with the report
and are automatically retrieved the next time you open the
report.

1.

Start DigiPro.

2.

Open a project database.

3.

Choose an installation.

4.

Click on the report that you want to modify.

5.

Click on the Open button.

1.

Click on either graph. The report properties dialog appears.

2.

The title bar shows which graph is active. To make the other
graph active, just click on it.

The title bar shows which graph is
active and can be modified.
Report properties are organized
by tabs. Click on a tab to display
its properties.
When you change a property,
click Apply to see the effect.

Click OK to close the dialog.
OK applies any remaining
changes.
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Click Apply to see the effect of your
changes. The dialog stays open so that
you can make more changes.
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Surveys

What is a Survey?

A survey is the data from one inclinometer survey. Each survey
is identified by date and time.

Survey Selection

DigiPro graphs only surveys that have been selected. Check
boxes for each survey indicate its selection status.

Sort

•

A check mark in the A column indicates that the survey is
auto-selected. New surveys are auto-selected so that DigiPro
can update graphs automatically. The Recent Surveys field
controls the number of auto-selected surveys.

•

A check mark in the + column indicates that the survey is
selected permanently. It will be used every time you run a
report. Click the box to check or uncheck.

•

A check mark in the – column indicates that the survey is
excluded permanently. Click the box to check or uncheck.

•

Surveys with no checkmark are not selected. When you have
many surveys, most of them will have this status.

Sorts the order of the surveys in the Selection window.
•

Ascending displays oldest survey first.

•

Descending displays newest survey first.

Recent Survey
Auto-Select

Specifies the number of new surveys to be automatically
selected for the report. To change the number, click the up and
down arrows next to the number. Then click apply.

Initial Survey

Shows which survey is used as the initial. DigiPro automatically
selects the oldest survey as the initial and puts a check mark in
the + column. To choose a different initial survey, scroll the
window until you can see it. Then right click on the + box and
choose “Mark as Initial Survey” from the pop-up menu. Note
that earlier surveys are ignored.

DigiPro for Windows, 2004/1/08
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Data Units

Unit
Conversion

The Unit conversion setting is provided for US users who need
metric-unit reports from their English-unit inclinometer
systems. These users should use the standard English-unit
templates and make the conversion here by clicking the radio
button for mm.
Other users will probably not need this setting because templates provide appropriate units automatically. Be sure to choose
metric templates for metric inclinometer systems and English
templates for English-unit inclinometer systems.
Troubleshooting Note: If you have used the correct templates

but your units and values appear strange, don’t try to correct the
problem with the units conversion setting. Instead, go back to
the Installation and Reports dialog, right-click on the installation, and choose “properties” from the pop up menu. Check that
Units is properly set to English or Metric (the same units as your
inclinometer system).
Scales
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•

Automatic: Sets full scale left and right to accommodate the
maximum values found in the surveys.

•

Manual: Allows manual control over the settings. Click on the
Manual button to show the fields below:

•

Full Scale Left: Enter a value to be used for full scale left.

•

Full Scale Right: Enter the value to be used for full scale right.

•

Tick every: Ticks are graduations on the data scale. For example, if you want a graduation every 10 mm, enter 10.

•

Label every nth tick: DigiPro will label every nth tick. For
example, enter a 2 to label every second tick. For example, if
ticks are 10 mm apart, labels will appear every 20 mm.
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Depth Units

Unit Conversion

The Unit conversion setting is provided for US users who need
metric-unit reports from their English-unit inclinometer
systems. These users should use the standard English-unit
templates and make the conversion here by clicking the radio
button for m.
Other users will probably not need this setting because templates provide appropriate units automatically. Be sure to choose
metric templates for metric inclinometer systems and English
templates for English-unit inclinometer systems.

Depth or Elevation

You can show depth-axis labels as depths or elevations. Click the
appropriate radio button. If you choose elevations, you must
also enter the elevation at the top of the casing. See depth offset
and elevation offset below.

Depth Offset

During a survey, depths are read from the control cable, which is
referenced to the top of the casing or (preferably) to the top of
the pulley assembly. If you want the depth-axis labels referenced
to ground level, enter an offset:

Pulley
Height

Depth Offset = casing height + pulley height
Casing
Height

Casing height is the height of the casing above ground level.
Pulley height is 1 foot or 0.3 meters.
Metric Example: The top of the casing is 0.5 meters above
ground level. The pulley assembly adds 0.3 meters. Enter 0.8
meters for the depth offset. Now the depth-axis label scale will
be referenced to ground level.
English Example: The top of the casing is 14 inches (1.17 ft.)
above ground level. The pulley assembly adds 1 foot. Enter
2.17 feet for the depth offset.

DigiPro for Windows, 2004/1/08
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Elevation + Offset

Pulley
Height

Casing
Height

If you want the depth-axis label referenced to elevations, first
click the radio button for elevations, then enter an offset:
Elevation Offset = ground elevation + casing height + pulley height

Casing height is the height of the casing above ground level. The
pulley assembly adds 0.3 meters (1 foot).
Metric Example: Ground elevation is 200 meters above sea level.
The top of the casing is 0.4 meters above ground level. The pulley assembly adds 0.3 meters. Enter 200.7 meters for the
elevation offset. Labels will be referenced to ground elevation.
English Example: Ground elevation is 1200 feet above sea level.
The top of the casing is 1.5 feet above ground level. The pulley
assembly adds 1 foot. Enter 1202.5 feet for the elevation offset.

Auto Depth Adjustment

With auto-depth adjustment turned on, DigiPro correctly plot
data points at the top (or bottom) of the measurement interval.
Auto-depth is turned on by default.
Why is an adjustment provided? Depth marks on Digitilt control cable are measured from the middle of the inclinometer
probe, but deviations and displacements are calculated for the
top (or bottom) of an interval.
Metric example: The depth stored with the inclinometer reading
is the cable depth of 20 meters, but the top of the interval is actually at 19.75 meters. With auto-depth adjust turned on, the plotted point will be placed correctly on the graph at 19.75 meters,
not at the cable depth of 20 meters.
English example: The depth stored with the inclinometer reading is the cable depth of 60 feet, but the top of the interval is
actually at 59 feet. With auto-depth adjust turned on, the plotted
point will be placed on the graph at 59 feet, not at the cable
depth of 60 feet.
On the graph, these adjustments are visually quite small, but if
you print out the data, you will see the adjusted depths.

DigiPro for Windows, 2004/1/08
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Scales

DigiPro sets the depth axis scales automatically, or lets you specify values for the top and bottom of the depth-axis scale.
Automatic: Automatically displays the entire depth-axis and

applies labels and ticks at multiples of 10.
Manual: Allows manual control of scales. Click on the Manual

button and enter the desired values in each field. If your report
shows elevations rather than depths, be sure to enter elevations
for top and bottom. Click Apply when finished.
•

Top: Enter a value for the top of the depth-axis scale.

•

Bottom: Enter a value for the bottom of the depth-axis scale.

•

Tick every: Ticks are graduations on the depth-axis scale. If
you want a graduation every 5 meters, enter 5.

•

Label every nth tick: DigiPro will label every nth tick. For
example, enter 2 to label every second tick. For example, if
ticks are 5 meters apart, labels will appear every 10 meters.

Tip: If you frequently zoom in to inspect a particular zone, you
might find it useful to make a report that shows only that zone.
Use manual scales to specify the top and bottom of the zone,
then save the result as a new report.

DigiPro for Windows, 2004/1/08
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Labels Tab

Editing a Label

DigiPro creates graph labels and legends automatically. This
dialog lets you change the automatic labels. If you want these
labels changed for all subsequent reports, save the report as a
template (See page 8).
1.

Click to remove the check mark from the Auto box above the
Label field. When the check is removed, you can edit the text.

2.

Enter text in the Label field. The Graph Label field accepts up
two lines of text. The Depth-Axis and Data-Axis fields accept
one line of text. The A button lets you choose a font.

3.

Click Apply to see your changes.

Note: If your Windows display is set for Large Fonts, text
appears larger on-screen than it prints on paper. Print the report
to see the true effect, then modify as needed.
Legend Position

Show Time
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DigiPro can place the legend in one of the four corners of the
graph. For example, if you click the upper right button in the
square, the legend will appear in the upper right corner of the
graph when you click Apply.
DigiPro can append time to the date in the legend. Normally
time is not required, but if you need it, click in the checkbox.
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Title Block

Function

The title block provides a place to enter information about the
graph. You can also include a company name, address, and company logo in the title block. If you want to add a logo to the title
block, use the Logo tab before setting the title block text.

Text Lines

DigiPro provides eight cells for text arranged into two columns.
Click in one of the eight fields to enter text. When finished, tab
to the next field. Click Apply to see the result on screen.
Note: The screen display of text is not accurate, especially if your
display is set for Large Fonts. Print the report to see the true
appearance of the text.
Tip: Save the report as a template so you can base future reports
on the same style with very little additional work. (See page 8).

Left Margin

Show Title Block

There are two left margin fields, one for each column of text.
Enter a percentage value, estimated from the left side of the
page. Then click Apply.
When the box is unchecked, DigiPro shows the title block. If
you hide the title block, you can enlarge your graphs using the
Layout tab.

Show Border

When the box is checked, DigiPro draws a line around the title
block. You may find that hiding the rule provides a neater result.

Position from Top

Enter an estimated percentage value. By default, the title block
appears at the bottom of the page. However, if you set the value
to zero, it will print at the top of the page.
Note: If you change the position of the title block, you must
move the graphs down using the Layout tab.

DigiPro for Windows, 2004/1/08
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Logo

Position settings

Displaying a Logo

DigiPro has a simple facility to print a bitmap (.bmp) image of
your logo on the report.
1.

Click (check) the Show check box.

2.

Enter the path and file name of your logo. You can use the
browse button to do this for you.

3.

The position settings are percentages. They change the
boundaries of the logo box and also the position of the logo
box. You will probably need to make several adjustments to
find the right setting.

Note: We recommend that you place the logo file in DigiPro’s
BMP folder so that it will not be accidentally lost during routine
disk cleanups. The path will appear like this: C:\Program
Files\DigiPro\BMP\myLogo.bmp.

DigiPro for Windows, 2004/1/08
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Graph Type

Overview

This useful feature lets you change the type of graphs shown in
the report. For example, you could place a graph of time displacement next to a graph of cumulative displacement. You
could also show two versions of the same graph, one with error
correction turned on and one with error correction turned off.

Graph Type

Graph types are explained in “Creating a Report.” The radio button shows the type of graph currently displayed. To change, click
a different radio button. When you click Apply, the graph is
redrawn.

Axis

The sample templates use A-axis data for the left graph and Baxis data for the right graph, but you are not limited by this. You
can show two A axis graphs or two B axis graphs, etc.

Horizontal

It is easier to use the Horizontal template to create a horizontal
graph, but this checkbox is here for completeness.

Reference

Select top or bottom of the casing as the starting point for calculations of cumulative displacement and cumulative deviation.
Bottom reference is the default.

DigiPro for Windows, 2004/1/08
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Error Correction

Overview

This dialog lets you enable and disable correction routines.
Except for the orientation correction, values used by the routines are entered elsewhere. For information on corrections, see
the chapter on error correction.
•

To enable a correction routine, put a check in its checkbox.

•

To disable a correction routine, remove the checkmark.

Report

Overview

This dialog is generally not used. Only two fields can be
manipulated: report name and graph shown.
Report Name: You can rename a report here. Note that you can

also rename a report by right clicking on the report in the
installations and reports dialog.
Graph Shown: This can be used to show a graph that was

previously hidden.

DigiPro for Windows, 2004/1/08
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Page Size

Overview

Page size and orientation are generally set by report templates.
Global defaults are controlled by settings in the File > Options
and Defaults dialog. The settings here affect only the current
report.

Paper Size

Controls paper size.

Orientation

Margins

Zoom

DigiPro for Windows, 2004/1/08

Controls the page orientation for the report. Choices are portrait (long side is vertical) or landscape (long side is horizontal).
Controls the page margins for the report. The default margin
values are in inches. If you select the A4 or B4 paper sizes, the
margin values automatically convert to centimeters.
Controls the screen size of the report. The default is “Fit Page,”
which allows the report and report properties to be displayed
on-screen simultaneously (with no overlap) on a monitor set to
a resolution of 800x600 or better.
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Layout

Overview
Distance from Top

Distance from Left

Visibility
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Layout settings determine the placement and size of each graph.
This controls the vertical size and placement of a graph.
1.

Click on a graph. An image of the graph appears in the dialog
box.

2.

Enter values for the top and bottom edges of the graph in percent from top of page.

This controls the horizontal size and placement of the graph.
1.

Click on a graph. An image of the graph appears in the dialog
box.

2.

Enter values for the left and right edges of the graph in percent from left side of page.

This controls whether a graph is visible or not. For example, if
you want only one graph on the page, you can hide the other
graph and then adjust size and placement of the visible graph as
needed.
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Zones

Overview

Zones

The zone tab is used to select zones for time-displacement
graphs.
You can graph up to five zones by specifying a start and stop
depth for each zone. Click the drop list to choose a valid depth
or elevation. The stop depth must be deeper than the start
depth.
The value that DigiPro plots is the difference between cumulative displacement at the start depth and cumulative displacement value at the stop depth.

Scales
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The automatic setting shows the number of days from the initial
survey. The manual setting lets you choose a start and an end
day to show only a portion of the available time span. You can
also set the frequency of tick marks (in days) and labels (numbers). The current version of DigiPro does not allow display of
dates.
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Printing a Report
Overview

Printing a Report

DigiPro offers the following options
•

Print report only or report with current survey data.

•

Print plotted data

•

Write plotted data to a file

1.

Open a report.

2.

Choose File>Print from the file menu, or click on the printer
icon located on the tool bar. The Print dialog appears.

3.

Click in the “Print What” field. Choose Report Only or
Report with Current Survey.

4.

Check the Printer window to be sure it displays the printer
you want. To change printers or adjust the printer setup, click
on the Printer Setup button.
Note: If you change the printer in DigiPro’s Print dialog, the
new printer becomes the Windows default printer.

5.

Click in the Copies field and enter the number of copies you
want.

6.

Select a print mode: color or black and white. (If you are using
a black and white printer but choose the color print mode, the
report will print in grayscale.)

7.

Click Print to print the report.

Note: You can change the colors that DigiPro uses, if some plots
are hard to see. Choose File>Options and Defaults>Preferences.
You will see a band of eight colors. click on the color that you
want to change and choose a different color from the pop up
menu.

DigiPro for Windows, 2004/1/08
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Printing Plotted Data

Writing Plotted Data

DigiPro for Windows, 2004/1/08

Plotted data are the
data points plotted on
the graph. DigiPro
can print a maximum
of 8 columns of data.
1.

Open a report and
click to open the
report properties
dialog.

2.

Place the pointer in
the Survey window
and right click.

3.

Choose Print Plotted Data from the pop-up menu.

You can write plotted
data to a file for use in
a spreadsheet. You
can write a maximum
of 8 columns of data
1.

Open a report and
click to open the
report properties
dialog

2.

When the Report
Properties dialog
appears, click in the
survey window.

3.

A menu appears. Choose Write Plotted Data.

4.

A submenu appears. Choose the items that you want to
appear in the file header. You can also specify a filename and
location if the default filename is not suitable.

5.

Click Write to write the data to the file. The file is placed in
the same folder as your project database. It has a .txt extension.
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Error Correction
Introduction

The error correction routines that are built into DigiPro were
requested by expert users. Error correction is not a simple subject, and applying corrections appropriately requires knowledge
and experience.
In this chapter, we provide an brief introduction to some aspects
of error correction. Those who need to know more should consider attending Slope Indicator’s short course on Data Reduction
and Error Correction. The course schedule is listed in the
Training section at www.slopeindicator.com.

Enable or Disable
Corrections

Correction values are stored separately from readings and are
applied on-the-fly when the graphs are generated. Thus
corrections can be enabled and disabled at any time

Use the report properties
dialog to enable or
disable corrections.
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•

Correction routines are disabled by default.

•

If you want to use correction routines, use the report properties dialog to enable them.

•

Correction routines apply at the graph level. Thus a report can
show one graph with corrections turned on and another
graph with corrections turned off.

•

Corrections values for casing are entered once for each installation and are applied to any survey selected for the graph.

•

Corrections values for sensors (inclinometer probes) are
entered for each survey that requires them. A special dialog
is used for this.
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Corrections for Casing
Orientation Correction

Spiral Correction

Corrections for casing are accessed with the report properties
dialog.
If casing grooves are not oriented to the direction of movement,
you can use DigiPro to mathematically rotate the orientation of
the measurement axes into the direction of interest.
1.

Enable the Orientation Correction. An entry field appears.

2.

Enter an orientation correction in degrees. For example, enter
10 to rotate the orientation 10 degrees clockwise.
Enter -10 to rotate orientation 10 degrees counterclockwise.

A spiral survey, obtained with a spiral sensor, provides measurements that can be used to correct for spiraled (twisted) casing.
The spiral survey is processed and placed in the database by
DMM for Windows. DigiPro has no entry fields for spiral data.
DigiPro automatically recognizes the spiral survey if it is
present. If DigiPro cannot find a spiral survey, the checkbox is
grayed out and cannot be enabled.

Corrections for Sensors

These corrections must be entered for each survey.
1.

Enable the correction.

2.

Click on the Surveys tab.

3.

Right click on the survey
that requires correction.
A dialog appears.

4.

Choose Enter Correction
Values. The Correction
Values dialog appears.

5.

Enter a value in the
appropriate field.

6.

Click Apply to see the
effect on the graph.

7.

Repeat steps 5 and 6 until
the correction value is
correct.

To enter values for the B axis, you
must click on the B-axis graph.

DigiPro for Windows, 2004/1/08
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Bias-Shift Error

What is
Bias Shift

Bias shift values are entered in reading units. Here is a simple
introduction to bias shift error. More information can be found
in the “Training” section of www.slopeindicator.com.
Bias: If you hold your inclinometer

probe absolutely vertical and check the
reading, you will typically see a non-zero
value. This is the probe’s bias. The bias
value is normally eliminated in the data
reduction process when the 0 readings
are combined with the 180 readings.
Bias-Shift Error: If the bias value changes

during a survey, the data reduction process cannot eliminate all of the bias. The
remaining value is error that is embedded in the reduced data.
The straight, but leaning plot at right is
the result of bias-shift error.

Identifying
Bias Shift Error

Appearance: A straightened, but leaning cumulative displace-

ment plot is a signature of bias shift error. The embedded error
grows larger at each interval, so the plot leans to the left or right.
Unlikely Behavior: The graph above shows rotation of the entire

150 foot span of soil or rock. This unlikely behavior suggests
error in the data.
Site Knowledge: The plot shows movement where there should

be no movement. Typically, the bottom 5 depths (or more) of
the casing are anchored in stable ground. Any movement
appearing there is generally error. In our example, we know that
the casing entered rock below 80 feet, and that no movement
has occurred from 80 feet downwards. This again suggests error
in the data.
Quantifying
Bias Shift Error

DigiPro for Windows, 2004/1/08

DMM for Windows has a routine for quantifying bias shift
error. It suggests an value that you can enter in DigiPro’s correction routine. Refer to the DMM manual for details.
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You can also arrive at an correction value visually.
1.

Display a cumulative displacement graph.

2.

Identify displacements that are produced by bias-shift error.
For example, if you know that the bottom 20 feet of the casing
are installed in rock, then any displacement seen there is
probably error. If the error appears as a straight line tilted
away from vertical, then it is probably due to bias-shift.

3.

Enable bias-shift corrections. Then right click on one of the
surveys, and choose Enter Correction Values.

4.

In the Corrections Value dialog, enter a value, typically less
than 20. If the tilt is to the right, enter a positive value. If the
tilt is to the left, enter a negative value.

5.

Click Apply and observe the graph. The tilted line should be
vertical when the error has been corrected. Experiment with
different values until you have found the correct one.
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This example shows uncorrected and corrected graphs. You can
see the typical linear pattern of bias-shift error. The second survey was obtained on the same day as the initial survey, so any
movement is certainly false. The second survey was taken a
month later and apparent displacement is in the wrong direction. When corrected, both surveys make sense and we can see
that some real movement has occurred at about 125 feet.
DigiPro for Windows, 2004/1/08
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Rotation

Rotation corrections are entered in radians. Here is a simple
introduction to “rotation” error. More information can be found
in the “Training” section of www.slopeindicator.com.

What is
Rotation Error?

Rotation is a small change in the alignment of the measurement

axis of the inclinometer probe. The change is usually less than
one degree.
Ideally, the mechanicals of the probe are aligned so that the
A-axis accelerometer measures tilt only in the A-plane. If the
mechanicals of the probe are rotated slightly towards the Bplane, the A-axis accelerometer becomes slightly sensitive to tilts
in the B-plane, too.
Rotation error is the cross-axis component in a reading, for

example, the B-axis tilt in the A-axis reading. Rotation error
becomes noticeable when two conditions combine:

Identifying
Rotation Error

•

There is significant inclination in the cross axis.

•

The change in the alignment of the probe occurs after the
initial set was taken.

•

The cumulative displacement plot shows a curved line, when
the line should really be straight.

•

The cumulative deviation plot shows significant tilt in the
cross axis.

•

The two plots have a similar shape, as shown below.

Cumulative
Displacement
A-Axis

DigiPro for Windows, 2004/1/08

Cumulative
Deviation
B-Axis
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Correcting
Rotation Error

1.

Display a cumulative displacement graph. Use surveys that
contain the error.

2.

Identify displacements that are produced by rotation error.
Find the depth of the maximum error.

3.

Display a cumulative deviation plot of the cross axis. Find the
deviation value at the same depth noted above.

4.

Divide the displacement value by the deviation value. The
result is a starting value for correcting rotation.

5.

In DigiPro, enable rotation corrections and enter the rotation
value.

6.

Apply the correction and inspect the redrawn plot. The curve
in the line should straighten..

Cumulative
Displacement
A-Axis

Cumulative
Deviation
B-Axis

Cumulative
Displacement
Corrected

This example was a comparison test of three inclinometer
probes. Readings from two probes are plotted against the third
probe. All readings were taken on the same day. The casing was
tilted about 4 degrees in the B-axis. The similarity between the
A displacements and the B profile signals rotation error. The
corrected displacement are shown at right.

DigiPro for Windows, 2004/1/08
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Options and Defaults
Overview

Some of DigiPro’s default settings can be changed by using
options and defaults dialog: File > Options and Defaults.

Page Setup

Paper Size
Orientation
Margins

Set the default paper size for all new reports.
Normally, you will allow report templates to take care of this.
Set page margins. Choose paper size first.

Preferences

Recent File List
Language
Colors

Open Graph

DigiPro for Windows, 2004/1/08

Sets the number of recent files displayed on the File menu.
Currently, the only choice is English. Sorry.
Set colors for DigiPro graphs by clicking on a color patch and
choosing a different color from the pop-up pallet.
Sets DigiPro’s window: normal is resizable, minimized is a task
on the task bar, maximized is full screen.
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Advanced Tab

Zoom Level

Show Fonts in Boxes

Allow DigiPro to
Control Window Positions

Sets the initial size of all displayed reports. We recommend
using the default “Fit Page.”
If unchecked, the text fields in the Title Block and Labels tabs
will display text in DigiPro’s default display font (Arial 10). If the
box is checked, the text fields will display text in the font you
select using the A button.
Starts the report window in the upper left corner of the screen
and the Report Properties dialog to the top edge of the screen.
If the box is not checked, the Windows system controls placement. This may be the preferred setting if you open multiple
windows.

Show Status of
Report Properties

If this box is checked, a grid appears at the bottom of the Report
Properties dialog. The grid lists the tabs in which changes have
been made. When you click Apply, the grid resets.

Show Tickmarks on Graph

When this box is checked, DigiPro displays tick marks on the
borders of the graphs. When the box is unchecked, the tick
marks do not appear. You can set the tick mark positions in the
Data Units and Depth Units tabs of the Report Properties
dialog.

Select Graph and...

Sets what happens when report properties dialog is closed and
then reopened.
•

Stay on Current Tab: This is the default. Report Properties
displays the same tab as you switch back and forth between
graphs.

•

Open Survey Tab: Report Properties shows the Survey tab
each time you switch between graphs.

Open Tab for Graph Item: Report Properties opens to the tab
that corresponds to the part of the graph that you clicked on.
DigiPro for Windows, 2004/1/08
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Appendix A: Project Databases
What is a
Project Database?

Use DMM to Create
the Database

Slope Indicator’s project databases contain:
•

Information about inclinometer installations, such as their
ID and depth. The database can contain any number of installations.

•

Surveys of the installations above. The database can contain
any number of surveys.

•

Reports created by DigiPro. A report is a collection of parameters that tell DigiPro how to create a graph. The database can
contain any number of reports.

Project databases are created by DMM for Windows. DMM also
imports or converts older data formats. DigiPro simply uses the
data in the database.
If you don’t have DMM for Windows, you can download it from
Slope Indicator’s website: www.slopeindicator.com or install it
from Slope Indicator’s Resource CD. DMM for Windows is free.

Use DMM to Convert
or Import Data

Converting .hdr Databases

Importing GTilt, RPP, and
PCSLIN Files

Project databases created by DMM for Windows have a “.mdb”
extension. If you have been using the Windows version of
DMM, your data are already in this format, so no conversion is
necessary.
Project databases created by DMM for DOS consisted of a number of files. The main file had an “.hdr” extension. DMM for
Windows provides a utility to quickly convert any of your old
.hdr files to the .mdb Windows format. See Appendix 3 of the
DMM manual: “Converting DOS DMM databases.”
DMM for Windows can import RPP, PCSLIN, or GTilt files. It
will also accept manually-entered data. See Appendix 5 and 6,
“Importing Data” and “Manual Entry of Data.”
If you are switching from some other inclinometer system to
Slope Indicator’s system, you can usually export your data in one
of these formats.
Note: DMM does not import spreadsheet files.

DigiPro for Windows, 2004/1/08
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